天行视点

天行视点®软件系列 之 写歌曲头文件使用手册
 | 开发商： 发行版本： 发行日期： | 广州市天汇计算机科技有限公司 1.0.0.0 2010年
地址：广州市天河区五山路137号天立大厦A-24E 电话：020-87567279 传真：020-87501320 http://www.SkyMedia.cn


运行环境

欢迎浏览天汇公司网站

运行环境

写歌曲头文件，是指根据歌曲ID，在数据库（songbook.mdb）中找到对应的歌曲信息（如歌曲名称、歌手等等）后将其写入到歌曲文件中（MPG文件），以方便KTV后台系统扫描（没有头文件信息的歌曲，KTV后台管理不能搜索到）。新的写歌曲头文件，还可以根据国家文化局的歌曲数据库（total_song.txt），写入相应的歌曲ID（即一首歌曲可以同时有2个ID：公司数据库ID和文化局数据库ID）。

写歌曲头文件程序一般运行在KTV服务器上：

配件名称 | 推荐配置
CPU | 2.5G或以上
内存 | 2GB或以上
主板 | G31或以上
网卡 | 千兆网卡

软件配置
操作系统：Windows Server 2003 SP2 简体中文企业版
其他： .NET Framework 2.0 运行库 （下载页面）

如没有安装.NET 2.0，写歌曲头文件程序会提示：.NET Framework 初始化错误。
地址：广州市天河区五山路137号天立大厦A-24E 电话：020-87567279 传真：020-87501320 http://www.SkyMedia.cn


开始写歌

浏览天汇公司网站

开始写歌

写歌曲头文件，是指根据歌曲ID，在数据库（songbook.mdb）中找到对应的歌曲信息（如歌曲名称、歌手等等）后将其写入到歌曲文件中（MPG文件），供KTV后台系统扫描（没有头文件信息的歌曲，后台不能搜索到）。写歌曲头文件，新增根据国家文化局的歌曲数据库（total_song.txt），写入相应的歌曲ID（即一首歌曲可以同时有2个ID：公司数据库ID和文化局数据库ID）。

歌曲头文件写入程序主要由数据库设置、写入头文件、过滤条件和读头文件信息等组成。

打开程序，主界面如图。

1、数据库设置： 默认数据库路径是和写歌曲头文件程序在同一文件夹，建议将songbook.mdb复制当前文件夹下。如不写国家文化局数据库ID，则“全国文化歌曲文件”不选中。如图。

点击展开 写歌示例1（不写文化局歌曲ID）

如图，首先将songbook.mdb复制到当前文件夹，打开数据库文件，确认表内的歌曲ID和硬盘上的歌曲文件ID对应（如找不到对应的记录，则不予写入）。没有写头文件信息的在“读头文件”时提示“此文件还没有写文件头，请先写入文件头。”

点击“确定并退出”后，程序会缓存数据库。

缓存完成后返回到主界面，选择E:\，点击“开始”按钮，开始写歌。

写入完成后，查看（修改）歌曲信息是否相符时，点击“读头文件”按钮。

选择硬盘分区。

点击某首歌曲，右侧会显示此文件的头文件详细信息，也可以添加相关字段的信息，点击“新改/写入”保存信息。

点击展开 写歌示例2（写文化局歌曲ID）

要写文化局歌曲ID，则在“数据库设置”必须选中“国家文化局歌曲数据库ID”，然后浏览打开文化局数据库（total_song.txt），如图。

正在更新数据库缓存。

songbook.mdb 和 total_song.txt 对比（歌名和歌星），一共有2首歌曲在文化局中找不到匹配记录）。

选中E:\，点击“开始”写歌。

正在“写歌”。

完成后，查看歌曲信息，确认是否添加了文化局数据库歌曲ID。

歌曲“无忌 （MTV）”和“幻影(08酷演)”在文化局中没有找到，实际上是由歌曲名字导致的，下面将此问题解决，忽略歌曲名字的“ (MTV)”。

点击展开 过滤条件（设置忽略条件匹配文化局数据库）

如上面的郭富城“无忌 （MTV）”在文化局中没有找到，实际上是由歌曲名字导致的，使用“过滤条件”可以解决此问题，忽略歌曲名字的“ (MTV)”。

点击“过滤条件”。

双击空白处，输入忽略条件，如(*、（*，表示忽略掉括号后面的字符。

打开“数据库设置”，打开文化局数据库。

设置忽略条件后，不匹配歌曲数目是0.

选择分区写入头文件信息。

完成后如图。
地址：广州市天河区五山路137号天立大厦A-24E 电话：020-87567279 传真：020-87501320 http://www.SkyMedia.cn